Intermittent 5XX errors and degraded performance in API and web platform

Incident Report for Volt

Resolved

This incident has been resolved. We intend to share a full post-incident review for this incident and the related outage in the coming days.
Posted Jul 09, 2025 - 22:38 UTC

Monitoring

A fix has been implemented and we are monitoring the results as our system fully recovers.
Posted Jul 09, 2025 - 20:15 UTC

Update

We have identified that a workflow within AWS infrastructure has become stuck, which is causing the ongoing delays and intermittent 5XX errors. This issue is a secondary effect stemming from yesterday's AWS outage and appears to be related to an underlying software fault within an AWS system.

Volt's Engineering team is actively working with AWS Support to resolve the stuck workflow. This issue requires AWS intervention to restore normal functionality, as it stems from their infrastructure.

We will continue to provide updates as we work with AWS to resolve this issue. For more details, questions, or concerns related to this incident, you can contact our Customer Success team via chat: https://help.textvolt.com
Posted Jul 09, 2025 - 18:37 UTC

Update

Volt has observed significant delays in core messaging webhooks related to this incident. We are continuing to work on a mitigation for this issue and will provide further updates as they become available.
Posted Jul 09, 2025 - 15:36 UTC

Update

We are continuing the process of mitigating the effects of this issue. We are temporarily load shedding access to the web platform in order to continue sending and receiving messages successfully. This is intended to be a temporary state which is resolved within the next 1-2 hours. We will continue to update as the situation progresses.
Posted Jul 09, 2025 - 14:29 UTC

Identified

Volt is currently experiencing temporary delays and intermittent 5XX errors as our system fully recovers from yesterday's outage: https://status.textvolt.com/incidents/ms4sppm7n20m

A fix is being implemented to mitigate the secondary effects of yesterday's outage. For more details, questions, or concerns related to this incident, you can contact our Customer Success team via chat: https://help.textvolt.com
Posted Jul 09, 2025 - 13:03 UTC
This incident affected: Messaging (Messaging App, GraphQL API, Core Messaging - Webhooks) and Insights (Insights App).